Lompat ke konten Lompat ke sidebar Lompat ke footer

Iklan 20211

Cara Membuat Wifi Voucher Dengan Mikrotik RB941

 

Cara Membuat Wifi Voucher Dengan Mikrotik RB941 - Apa kabar teman-teman blog semua? semoga teman-teman semua sehat selalu ya walaupun pandemi belum berakhir. kali ini saya akan membuat tutorial cara membuat wifi voucher, kalau belum tau apa itu wifi voucher saya akan jelaskan sedikit umumnya wifi voucher seperti wifi id punya telkom, dimana jika ingin terhubung kejaringan wifi id kita diharuskan membeli vouchernya terlebih dahulu di vouchernya terdapat kode yang harus dimasukkan jika ingin mengakses internet melalui wifi id. jadi intinya setiap orang yang ingin terhubung ke hotspot wifi voucher yang akan kita buat harus mempunyai kode unik yang akan kita buat nantinya, kodenya bisa kita buat dalam bentuk voucher atau yang lain. kita juga bisa menentukan sendiri masa aktif wifi sampai batasan kuota yang dapat diakses user hotspot.
    syarat untuk membuat wifi hotspot voucher atau cara membuat voucher wifi hotspot yaitu sudah mempunyai akses internet, bisa menggunakan Modem GSM maupun ISP Fiber, Winbox untuk mengatur mikrotik dan alatnya sendiri yang akan digunakan di tutorial cara membuat voucher wifi Mikrotik RB941-2nd. 

Spesifikasi mikrotik RB941-2nd :
Storage 16 MB
Ram 32 MB
Port Lan 4
Integrated Wireless (Wifi Internal)
Power 5 watt

Gambar topologi jaringan yang akan dibangun.

    Dari Gambar topologi diatas dapat dilihat ada 4 buah port lan dimikrotik rb941 dimana port lan 1 terhubung ke sumber internet (bisa menggunakan modem GSM atau ISP Fiber). Port lan 2 terhubung ke Komputer atau Laptop nantinya juga bisa diganti menjadi akses point sehingga alat yang lain seperti smartphone komputer dan laptop juga bisa terhubung ke internet. Port lan 3, port lan 4 dan wifi bawaan mikrotik akan dijadikan interface bridge tujuannya untuk melebarkan / meluaskan wifi hotspot voucher yang dibuat. port lan 3 dan 4 akan menyebarkan hotspot wifi voucher melalui akses point.

Berikut Caranya :
Langkah 1 Masuk ke winbox
Gambar 1
  • Hubungkan port lan 1 ke sumber internet dan port lan 2 ke komputer / laptop
  • Buka winbox, klik pada menu "neighbors", mac mikortik akan otomatis terbaca
  • Pada Kotak Connect To: isi dengan mac address yang terbaca dengan Username: admin dan Password: kosong.
Langkah 2 Mengganti Password Mikrotik
Gambar 2

    Untuk keamanan ganti dulu password yang kosong agar tidak terjadi hal yang tidak diinginkan. cara mengganti password mikrotik yaitu buka menu System Password Old Password isi password sebelumnya, jika tidak ada dikosongin saja. lalu masukkan password baru dan konfirmasi, kemudian tekan tombol Change. Silahkan sobat keluar dulu dari winbox kemudian masuk lagi dengan password yang sudah diganti.

Langkah 3 Mengaktifkan DHCP Client Mikrotik
Gambar 3

    Mengaktifkan DHCP Client tujuannya agar mikrotik terhubung ke sumber internet melalui port lan 1 caranya yaitu dengan membuka menu IP DHCP Client → Tekan Tanda  "+" → Interface pilih ether1 (sesuai dengan topologi). Kemudian tekan tombol Apply dan OK
Script :
/ip dhcp-client add dhcp-options=hostname,clientid disabled=no interface=ether1
Langkah 4 Mengaktifkan SNTP Client di Mikrotik
Gambar 4

    Simple Network Time Protocol atau disingkat SNTP merupakan fitur mikrotik yang bisa digunakan sebagai NTP Client. Pada saat mikrotik dihidupkan akan otomatis melakukan sinkronisasi waktu terhadap NTP Server yang ditunjuk sehingga pengaturan waktu akan tetap terupdate. disini saya akan menggunakan NTP dari citra net. Caranya yaitu buka menu System  SNTP Client  Aktifkan / Beri Centang Enable  isi primary ntp server dengan 202.65.114.202 dan secondary ntp server dengan 119.82.243.189Kemudian tekan tombol Apply dan OK
Script :
/system ntp client set enabled=yes primary-ntp=202.65.114.202 secondary-ntp=119.82.243.189
Langkah 5 Mengatur Zona Waktu Mikrotik
Gambar 5

    Selain dengan cara Mengaktifkan SNTP Client untuk mengatur waktu atau jam, kita juga bisa mengatur waktu melalui zona wilayah. caranya buka menu System  Clock  Pilih zona waktu wilayah sobat. terakhir tekan tombol Apply dan OkTujuan dari update waktu agar nantinya tidak ada kendala / masalah saat membuat limit waktu di hotspot. karena waktu sangat berpengaruh dengan voucher yang akan dibuat.
Script:
/system clock set time-zone-autodetect=yes time-zone-name=Asia/Jakarta
Langkah 6 Mengaktifkan Wireless Mikrotik (optional)
Gambar 6

    Jika mikrotik yang sobat gunakan tidak mempunyai wireless internal / wifi lewati saja langkah ini. wifi mikrotik akan digunakan sebagai penyebar wifi hotspot, Cara mengaktifkan wifi di mikrotik yaitu buka menu wireless  klik 2x pada interface wifi  buka tab "Wireless Sesuaikan dengan Gambar 6  Tekan tombol "Enable jika ada peringatan pilih "Yes". akhiri dengan Apply dan OK.
Script:
/interface wireless set [ find default-name=wlan1 ] disabled=no mode=ap-bridge ssid=Hotspot-Serupting
Langkah 7 Membuat Password Wifi Mikrotik (optional)
Gambar 7

    Sobat juga bisa melindungi wifi mikrotik dengan password tapi saya sarankan tidak usah dibuat karena akan membuat sebagian orang menjadi tidak nyaman, tapi kalau mau di password ya tidak apa apa juga. Berikut cara membuat password wifi mikrotik yaitu menu "Wireless Buka Tab "Security Profiles Sesuaikan dengan gambar 7 dan pada kolom WPA2 Pre-Shared Key: isikan password wifi sobat  Apply dan OK.
Script:
/interface wireless security-profiles set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=123123123
Langkah 8 Membuat Interface Bridge1 Mikrotik
Gambar 8

    Fungsi bridge yaitu menggabungkan beberapa interface seperti port lan dengan wifi di mikrotik sehingga bridge tersebut berada dalam satu segment ip. sesuai dengan topologi yang sudah dibuat saya akan menggabungkan port lan 3, 4 dan wireless Cara Membuat Interface Bridge yaitu, Buka menu "Bridge Tekan Tombol "+"  name nya teserah mau dibuat apa (default bridge1 Apply dan OK
Script:
/interface bridge add name=bridge1
Gambar 9

    Masih di menu "Bridge Buka tab "Ports Tekan tombol "+"  Interface pilih "wlan1", Bridge pilih "bridge1 Apply dan OK. Ulangi langkah 6, 7 dan 8 untuk interface ether3 dan ether4 sehingga hasilnya akan menjadi seperti nomor 9.
Script:
/interface bridge port add bridge=bridge1 interface=wlan1
/interface bridge port add bridge=bridge1 interface=ether3
/interface bridge port add bridge=bridge1 interface=ether4
Langkah 9 Cara Membuat IP Address
Gambar 10

    Langkah membuat ip address yaitu buka menu "IP→ Pilih "Address Tekan tombol "+"  Address : 192.168.2.1/24 (IP yang akan dihubungkan ke komputer). Network : 192.168.2.0. Interface : ether2  Apply dan OK. Ulangi langkah 3, 4 dan 5 untuk interface bridge1. Sehingga hasilya akan terlihat seperti nomor 6
Script:
/ip address add address=192.168.2.1/24 interface=ether2 network=192.168.2.0
/ip address add address=192.168.3.1/24 interface=bridge1 network=192.168.3.0
Langkah 10 Membuat DHCP Server Mikrotik
Gambar 11

Gambar 12

    Dengan membuat DHCP Server nantinya perangkat yang terhubung ke mikrotik / wifi voucher akan mendapatkan IP secara otomatis. Cara Membuat DHCP Server Mikrotik buka menu "IP DHCP Server  DHCP Setup  DHCP Server Interface: Pilih interface yang akan dibuat ip otomatis (ether2 dahulu) Kemdian "Next"  DHCP Address Space: Biarkan saja terisi, Kemudian "Next Gateway for DHCP Network: Biarkan saja terisi, Kemudian "Next Addresses to Give Out: buat range 192.168.2.11-192.168.2.254. Nantinya IP yang tidak digunakan (192.168.2.2 sampai 192.168.2.10) akan dijadikan IP untuk remote akses point, Kemudian "Next DNS Server: Sobat bisa memasukkan penyedia dns seperti dns google (8.8.8.8) atau dns yang lainnya. atau biarkan terisi otomatis, Kemudian "Next Lease Time: Biarkan saja 10 menit, Kemudian "Next". kalau berhasil akan muncul notif sukses. Ulangi langkah 3 sampai 11 untuk interface bridge1 dengan memperhatikan IP yang akan digunakan tentunya.

Hasil Membuat DHCP Server untuk ether2 dan bridge1
Gambar 13
Script:
/ip pool add name=dhcp_pool0 ranges=192.168.2.11-192.168.2.254
/ip pool add name=dhcp_pool1 ranges=192.168.3.11-192.168.3.254

/ip dhcp-server network add address=192.168.2.0/24 gateway=192.168.2.1
/ip dhcp-server network add address=192.168.3.0/24 gateway=192.168.3.1

/ip dhcp-server add address-pool=dhcp_pool0 disabled=no interface=ether2 name=dhcp1
/ip dhcp-server add address-pool=dhcp_pool1 disabled=no interface=bridge1 name=dhcp2
Langkah 11 Membuat NAT Mikrotik
Gambar 14

    Agar perangkat dapat mengakses internet kita harus membuat NAT terlebih dahulu  cara Membuat NAT Mikrotik, Buka menu "IP Pilih "Firewall Buka tab "NAT Tekan tombol "+ Chain: Pilih "srcnat" dan Out. Interface: pilih "ether1" (pilih port lan sumber internet)  Pilih tab "Action Action: pilih "masquerade Apply dan OK. sekarang kamu dapat mencoba apakah komputer sudah bisa mengakses internet atau belum.
Script:
/ip firewall nat add action=masquerade chain=srcnat out-interface=ether1
Langkah 12 Membuat Interface Hotspot Mikrotik
Gambar 15

Gambar 16

    Langkah berikutnya membuat interface hotspot caranya, Buka menu "IP Pilih "Hotspot Pilih "Hotspot Setup Hotspot Interface: pilih "bridge1" yang sudah dibuat tadi, kemudian "Next Local Address of Network: biarkan saja terisi, kemudian "Next Address Pool of Network: biarkan terisi, kemudian "Next Select Certificate: pilih "none", kemudian "Next IP Address of SMTP Server: biarkan saja 0.0.0.0, kemudian "Next", DNS Servers: biarkan saja terisi (jika kosong, isikan saja gateway ip yang sudah dibuat tadi), Kemudian "Next DNS Name "masukkan url hotspot / url login page yang akan sobat gunakan", kemudian "Next Name of Local Hotspot User: masukkan username dan password (administrator) hotspot sobat. Kemudian "Next Jika muncul notif sukses, berarti sobat sudah berhasil membuat interface hotspot.

Langkah 13 Mengatur Interface Hotspot
Gambar 17

Gambar 18

    Sekarang setting mac address device agar menjadi 1, cara Mengatur Interface Hotspot masih di menu hotspot (Lihat gambar 17)  klik 2x interface "hotspot1"  Address Per Mac: buat jadi "1"  Apply dan OK.
Buka tab "Server Profiles"   klik 2x interface "hsporf1"  pilih tab "Login" dan centang "HTTP CHAP, HTTP PAP dan Mac Cookie"  Apply dan OK
Script:
/ip hotspot profile add dns-name=serupting.net hotspot-address=192.168.3.1 login-by=http-chap,http-pap,mac-cookie name=hsprof1
/ip hotspot user add name=admin password=123456

/ip hotspot add address-pool=dhcp_pool1 addresses-per-mac=1 disabled=no interface=bridge1 name=hotspot1 profile=hsprof1
Langkah 14 Mengatur DNS Server
Gambar 19

    Langkah terakhir yaitu mengatur DNS Server tujuannya agar langsung redirect ke login page ketika terhubung ke wifi hotspot. Caranya buka menu "IP"  Pilih "DNS"  Server: Isikan ip gateway hotspot yaitu interface bridge1 (192.168.3.1), beri centang juga pada "Allow Remote Request"   Apply dan OK
Script:
/ip dns set allow-remote-requests=yes servers=192.168.3.1
Tampilan Login Hotspot
Gambar 20

    Selain dengan cara manual, sobat juga bisa Membuat Wifi Voucher Dengan copy-paste script diatas ke terminal mikrotik caranya buka terminal lalu copy dan paste script diatas, jangan lupa ketika selesai paste untuk menekan tombol enter, agar memastikan script terpasang dengan baik. cara membuat hotspot mikrotik ini merupakan bagian awal dari pembuatan wifi voucher, kedepannya kita akan menghubungkan mikrotik yang sudah di setting dengan MIKHMON. cara diatas juga bisa digunakan untuk semua mikrotik yang mempunyai lisensi level 4. kebetulan yang sudah saya coba rb941, rb951 dan rb750gr3
    Demikianlah tutorial saya yang berjudul Cara Membuat Wifi Voucher Dengan Mikrotik RB941 semoga bermanfaat untuk sobat yang lagi belajar mikrotik. jangan lupa di share ke teman teman sobat semua. terimakasih.

Posting Komentar untuk "Cara Membuat Wifi Voucher Dengan Mikrotik RB941"